• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

High CPU used by NS.EXE

I installed Norton Security last week, replacing Norton 360.  This is on Win/XP SP3.  This machine runs several Servers that receive remote connections.  Everything runs slowly now so I am looking at the Windows Task Manager.  The CPU is running 80-100% (Intel core2 CPU 4300 1.8 Ghz).  The process NS.EXE is constantly using 30+% of the CPU.  With no applications running my machine now idles at around 50% CPU.  With the Servers up, at times socket connections cannot be made or existing connections are dropped.  I have tried turning off all the various parts of Norton Security with no change.  When I use Task Manager to kill the ns.exe process the CPU immediately drops to normal levels and everything runs fine but of course I have no security.  I don't see this problem on my Win7 machines.  Are there any settings that might help me, or am I just going to have to uninstall this thing?

Replies

Kudos0

Re: High CPU used by NS.EXE

If you are able to kill ns.exe, you have a problem. Make sure you have not turned off Norton Product Tamper Protection. If you can turn off the protection, so can some malware.

Try changing all Norton settings to defaults. Then when you see the cpu spikes, see if turning on Silent Mode will help. Right click on the Norton icon in the system tray and choose Turn on Silent Mode. Your system will still be protected, but no background tasks will be run.

How much ram do you have on this system?

What was the cpu usage when you had 360 installed?

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: High CPU used by NS.EXE

You are right about the Tamper Protection.  You can't terminate the process with that on.  I  used the UI and turned off features one at a time trying to find something that would stop the CPU usage.  So, I had everything disabled when I killed the ns.exe process.

I just uninstalled NS, ran the Removal Tool and re-installed.  It is doing the same thing again so I turned on Silent Mode and that made no difference either.

The box has 4gb of RAM installed but of course XP only uses 3.25gb max.

Normally it runs 15-50% CPU (with 360) when there is activity on the Servers running on the box but with NS running it is at 80-100%.  I have another XP machine and a Win7 machine and neither of them are having this issue.  I can't upgrade this machine to Win7 without also upgrading a lot of other software that runs on it, requiring a decent amount of down time that I can't handle right now.

Kudos0

Re: High CPU used by NS.EXE

I never found a solution to this issue or received any additional suggestions.  I was forced to bite the bullet and upgrade from XP to Win7.  I do not have the issue running under Win7.

Kudos0

Re: High CPU used by NS.EXE

Hello chuck_arney

I am glad you got your problem fixed. Sorry you didn't get any more suggestions from the Community. Good luck with your new computer.

Success always occurs in private and failure in full view. Windows 10 Pro 64 bit Norton Core Security Plus 22.18.0.213 Core Firmware 282 I E 11 Chrome latest version.

This thread is closed from further comment. Please visit the forum to start a new thread.