• All Community
    • All Community
    • Forums
    • Blogs

Not what you are looking for? Ask the experts!

This forum thread needs a solution.

Identity Safe passwords don't show for new and edited logins

I have an Identity Safe problem that has only occurred since I upgraded my computer a few months ago.

I can log into Identity Safe successfully.  The problem occurs when I create a new login (for example, for a bank account).  The password field does not show any characters at all as I type, not even the usual dots.  Despite this, if I save the new login, the saved password can still be viewed in the list of logins.

A similar problem happens when I edit an existing login.  I've attached a screen print.  Even though there is a password, the password field appears as a blank white space (surrounded by a red, amber or green border, depending on how secure the password is).  However, if I click the apparently empty space, the cursor goes to wherever the end of the password is.  I still can't see any characters, but if I highlight where they should be, then copy and paste into Word, the password will appear correctly (in Word).

My computer is a Dell XPS13 Touch with HD screen.  I use Windows 10, with the recent updates.  I've just checked Norton's website and I have the latest version of Norton 360.  My problem is with the Identity Safe stored on my computer, not the online version.

Does anyone know if there is a fix for this problem?



Re: Identity Safe passwords don't show for new and edited logins

Hi David Mac,

Does the "eye"  and the + work?  I notice the last modified date is 9/7/2015 ?

You said you have the latest version of N360 - please go to the main page of N 360 and select  Help > About  and tell us what the full version is.  If you used the Check for New Version - it wil only report a new version when the first 2 digits of the version change - like from v 21 to v 22.  It will not tell you if you are current with the minor number of the version.

Vault stored on your computer - are you running a Local Vault?  Are you by chance on the Comcast version of Norton?

Sorry for all the questions - just trying to get this straight in my head.

Oh BTW - do you have Win 10 Fast Startup disabled?


Re: Identity Safe passwords don't show for new and edited logins


Thanks for taking the trouble to reply.  No need to apologize for the questions!  The answers are as follows:

  1. The “eye” icon (to view the password) and the “+” icon (to copy the password to the clipboard) both work correctly.
  2. The last modified date refers (I think) to the date the particular record was modified, not the last time N360  was updated.  For example, in the RadioShack record I posted on the forum, the date would have been the last date that I updated the RadioShack details.  I have checked this by looking at some other records: they have different dates.
  3. The version number is
  4. Yes, I think I do run a local vault, because I don’t necessarily have to connect to the internet to access my details.
  5. I have no contact at all with Comcast, so I don’t have their version of Norton.
  6. Windows 10 Fast Startup was enabled by default.  I’ve tried disabling it, then rebooting the PC.  This had no effect at all on the password visibility problem, so I’ve re-enabled it.

Thank you.



Re: Identity Safe passwords don't show for new and edited logins


Using the restart method is the same thing as disabling Fast Startup. Disabling of Fast Startup would take longer than just a reboot to see if it has any affect.


Success always occurs in private and failure in full view. Windows 10 Pro 64 bit 2004 N 360 Chrome latest version.

Re: Identity Safe passwords don't show for new and edited logins

Hello again,

I wasn't quite sure what you were asking me to do, so I've tried the following:

1. Just restarting the computer.

2. Disabling Fast Startup through the Control Panel.

3. Restarting after disabling Fast Startup through the Control Panel.

4. Completely shutting down the computer after disabling Fast Startup through the Control Panel, then booting the computer from cold.

None of these had any effect on the problem.

Thank you.


This thread is closed from further comment. Please visit the forum to start a new thread.