• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs

Not what you are looking for? Ask the experts!


Norton Security Blocks Package Updates For Latest Anaconda 2019.07 with Python 3.7.3

Just wanted to help out anyone in a similar predicament.  I downloaded and installed the latest version of Anaconda 2019.07 with Python 3.7.3 to pursue an online course on Deep Learning in Artificial Intelligence using TensorFlow and Keras (Google Neural Network products).  These latter two packages need to be added to the install via "conda install tensorflow" and then after that's complete, "conda install keras." in the right Anaconda software environment.  The anaconda underpinnings attempt to open an SSL socket and download the required packages from a secure repository over the Internet.  In spite of the fact that the basic Anaconda package was installed with the latest version of Norton Security running on my computer, either the Anaconda developers or Norton Security programmers did not grant the requisite permissions to the conda Internet connection.  The https:// connection tries always timed out with too many attempts made....   I spent hours trying to configure my Anaconda install, define the right software environment, check DLL's in the program, etc.  Then, DUH!, the idea occurred to me: "Maybe it's the Norton FIrewall."  I temporarily disabled the Norton Firewall using the Norton SysTray applet.  BAM!  "conda install" worked like gangbusters to install Google's TensorFlow and Keras and in a Juypter Notebook, I was able to run the Python code that required these underpinnings in my Juypter notebook.  I uninstalled Norton Security from the computer, running Windows Defender for the moment, and will see if Norton Security installed on top of the existing install of Anaconda 2019.07 lets the CONDA package updates work as they should (the reverse install order of what I did before).  If not, Norton Security has little future life on the open-source computer that I am dedicating to machine learning.  I suggest that Norton Security get together with the Anaconda folks and figure how why Norton kills the updates but Windows Defender works fine.  I did not get any warning that any process was requesting Internet access and I was not asked to allow or block any process.  When I searched on firewall settings for "conda," the only two things relevant that came up (besides vestigial detritus) were python.exe (blocked) and pythonw.exe (allowed).  Not knowing much about these things, I did not want to write a blank check for "python.exe" and decided it was easy just to switch supposedly secure Internet software (Norton to Windows Defender).

Basically, this seems like a situation where Norton is blocking something and not telling the user that it is doing so.



Re: Norton Security Blocks Package Updates For Latest Anaconda 2019.07 with Python 3.7.3

P.S. I should note that I had an earlier version of Anaconda with an earlier version of Python (3.6.5) that was installed under Visual Studio 2017 Community.  The "conda install" to the Internet would work and download both TensorFlow and Keras to my computer but they weren't properly hooked up to my Anaconda/Jupyter software environment and the Python code would complain that I was lacking the TensorFlow backend.  So I uninstalled everything to do with Visual Studio, Anaconda, Python, and did a fresh install of JUST Anaconda 2019-07 with Python 3.7.3 (which was the recommended version of Python for the online course, anyway) - no more Visual Studio.  I examined my Path environmental statements and deleted any leftover paths for the previous version of Anaconda installed under Visual Studio 2017.  The most important and relevant thing is that just turning off the Norton Firewall allowed the new Anaconda distribution to function perfectly and Norton Firewall gave me no warning about Internet access being blocked (for a counter example, every time I run Typora, Norton warns that Internet access is being requested and do I want to allow or block, and ALWAYS or JUST THIS TIME?).

This thread is closed from further comment. Please visit the forum to start a new thread.