• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs

Not what you are looking for? Ask the experts!

This forum thread needs a solution.

Norton Security Premium

Ever since I renewed my Norton product with the Norton Security Premium the backups that I can do seems to be FULL back ups cos it took a long time to complete. I thought that when I renewed my Norton product it would know how to look up my LAST BACKUP and do an incremental back up so it wouldn't take too long, but instead it started a new FULL BACK UP. And several weeks later Norton advised that I hadn't backed up for some time, so yesterday I did a FIX of the problem and AGAIN it did a FULL BACK UP for me again. Very Annoying!! Chatted to one of the guys and he told me it would back up from my LAST BACKUP. But it didn't. I could see my the new Norton SP could 'see' my LAST BACK UP (it showed something like 3rd Mar 2015 - which was named by me) but I just couldn't use it to start my back up from.

Will appreciate it if someone could explain why I have to do FULL BACKUPS every time Norton told me I have a back up problem to FIX. I hope when I do the 3rd one and all the following ones I don't have to do FULL BACK UPS all the time. Takes too long - there are 100K+ files to backup plus other stuff?

Labels: Backup



Re: Norton Security Premium

byFriday, have a look at this post from Guru Dick Evans; https://community.norton.com/en/comment/4665913#comment-4665913


"From DOS to Windows10 what a journey it has been" / MS Certified Professional / Windows 10 Home / Professional x 64 version 1903 / build 18362.295 / N360 Deluxe / Norton Core v.282 on Android 2.00

Re: Norton Security Premium

Has Norton fixed the power eraser tool yet. I have never been able to scan for root kits. I have tried on a brand new, out of the box IBM K series desktop and same results. (ambiguous error code that does not tell me why it failed). This time I am not going to include details because I have worked with support, and tried suggested solutions. Nothing gets this tool to complete.

Question: Has anyone been able to get power eraser to work?

This thread is closed from further comment. Please visit the forum to start a new thread.