• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

Kudos0

Norton Vulnerability Protection Will Not Update in Firefox

I've been running Firefox 16 and NIS 20.2.0.19  for a while now with no problems with the Norton Toolbar, and I decided to update to FF 17.0.1.  Before I updated to FF 17, I noticed my toolbar extension was 2013.2.2.3 but my Vulnerability extension is 11.1.1.5 -2 instead of the more recent -3.  Apparently my toolbar updated by my NVP extension never did.  I still updated to FF 17.0.1 without any problems.  My Norton extensions/toolbar are working fine, but the NVP is still 11.1.5-2.  It seems to still getting updates as the FF add-on manager says that 11.1.1.5-2 was updated as recently as today and it's enabled in the add-on menu.

To try and get the NVP extension to update, I decided to follow Yank's advice from other threads and did the following:

- Uninstalled Firefox

- Downloaded new copy of 17.0.1 and installed

- Downloaded NIS from www.norton.com/nis20

- Removed current NIS

- Installed fresh NIS and performed lave updates and reboots

I know it had to reboot a few times and installed a patch bringing me back up to 20.2.0.19.  It definatly downloaded the FF norton toolbar update as I saw the update and it's listed in my history archive.

Yet after all the updates, FF still is showing NVP extension version 11.1.1.5-2.  Again, everything is working fine, so I guess if it's not broke don't fix it, but why the heck is my NVP not updating to 11.1.1.5-3?  Other things I checked:

- I reset/deleted my extension.ini files in FF and it did re-install the extensions but it was still the -2 version.

- What's interetsing is when I check the install.rdf file in

C:\ProgramData\Norton\{0C55C096-0F1D-4F28-AAA2-85EF591126E7}\NIS_20.2.0.19\IPSFFPlgn

It definatly say version 11.1.1.5-2 with a min version of FF 3 and max version of 18.*   I guess that's saying that my NIS wants to go with this version of of the NVP extension until FF 18?

Like I said I really don't want to mess things much more as I'm currently not having any issues, but I guess I'm a little concerned that eventually my 11.1.1.5-2 will not longer be compatible with future versions of FF.  Maybe it will update on it's own with the toolbar patch before FF18.

Anybody have any other idea to look into as to why I'm not getting 11.1.1.5-3 as an extension update?

Thanks

Replies

Kudos0

Re: Norton Vulnerability Protection Will Not Update in Firefox

I've been running Firefox 16 and NIS 20.2.0.19  for a while now with no problems with the Norton Toolbar, and I decided to update to FF 17.0.1.  Before I updated to FF 17, I noticed my toolbar extension was 2013.2.2.3 but my Vulnerability extension is 11.1.1.5 -2 instead of the more recent -3.  Apparently my toolbar updated by my NVP extension never did.  I still updated to FF 17.0.1 without any problems.  My Norton extensions/toolbar are working fine, but the NVP is still 11.1.5-2.  It seems to still getting updates as the FF add-on manager says that 11.1.1.5-2 was updated as recently as today and it's enabled in the add-on menu.

To try and get the NVP extension to update, I decided to follow Yank's advice from other threads and did the following:

- Uninstalled Firefox

- Downloaded new copy of 17.0.1 and installed

- Downloaded NIS from www.norton.com/nis20

- Removed current NIS

- Installed fresh NIS and performed lave updates and reboots

I know it had to reboot a few times and installed a patch bringing me back up to 20.2.0.19.  It definatly downloaded the FF norton toolbar update as I saw the update and it's listed in my history archive.

Yet after all the updates, FF still is showing NVP extension version 11.1.1.5-2.  Again, everything is working fine, so I guess if it's not broke don't fix it, but why the heck is my NVP not updating to 11.1.1.5-3?  Other things I checked:

- I reset/deleted my extension.ini files in FF and it did re-install the extensions but it was still the -2 version.

- What's interetsing is when I check the install.rdf file in

C:\ProgramData\Norton\{0C55C096-0F1D-4F28-AAA2-85EF591126E7}\NIS_20.2.0.19\IPSFFPlgn

It definatly say version 11.1.1.5-2 with a min version of FF 3 and max version of 18.*   I guess that's saying that my NIS wants to go with this version of of the NVP extension until FF 18?

Like I said I really don't want to mess things much more as I'm currently not having any issues, but I guess I'm a little concerned that eventually my 11.1.1.5-2 will not longer be compatible with future versions of FF.  Maybe it will update on it's own with the toolbar patch before FF18.

Anybody have any other idea to look into as to why I'm not getting 11.1.1.5-3 as an extension update?

Thanks

Kudos0

Re: Norton Vulnerability Protection Will Not Update in Firefox


Brocktoon wrote:

I've been running Firefox 16 and NIS 20.2.0.19  for a while now with no problems with the Norton Toolbar, and I decided to update to FF 17.0.1.  Before I updated to FF 17, I noticed my toolbar extension was 2013.2.2.3 but my Vulnerability extension is 11.1.1.5 -2 instead of the more recent -3.  Apparently my toolbar updated by my NVP extension never did.  I still updated to FF 17.0.1 without any problems.  My Norton extensions/toolbar are working fine, but the NVP is still 11.1.5-2.  It seems to still getting updates as the FF add-on manager says that 11.1.1.5-2 was updated as recently as today and it's enabled in the add-on menu.

To try and get the NVP extension to update, I decided to follow Yank's advice from other threads and did the following:

- Uninstalled Firefox

- Downloaded new copy of 17.0.1 and installed

- Downloaded NIS from www.norton.com/nis20

- Removed current NIS

- Installed fresh NIS and performed lave updates and reboots

I know it had to reboot a few times and installed a patch bringing me back up to 20.2.0.19.  It definatly downloaded the FF norton toolbar update as I saw the update and it's listed in my history archive.

Yet after all the updates, FF still is showing NVP extension version 11.1.1.5-2.  Again, everything is working fine, so I guess if it's not broke don't fix it, but why the heck is my NVP not updating to 11.1.1.5-3?  Other things I checked:

- I reset/deleted my extension.ini files in FF and it did re-install the extensions but it was still the -2 version.

- What's interetsing is when I check the install.rdf file in

C:\ProgramData\Norton\{0C55C096-0F1D-4F28-AAA2-85EF591126E7}\NIS_20.2.0.19\IPSFFPlgn

It definatly say version 11.1.1.5-2 with a min version of FF 3 and max version of 18.*   I guess that's saying that my NIS wants to go with this version of of the NVP extension until FF 18?

Like I said I really don't want to mess things much more as I'm currently not having any issues, but I guess I'm a little concerned that eventually my 11.1.1.5-2 will not longer be compatible with future versions of FF.  Maybe it will update on it's own with the toolbar patch before FF18.

Anybody have any other idea to look into as to why I'm not getting 11.1.1.5-3 as an extension update?

Thanks


Hi Brocktoon,

I have just checked my NIS 2013 and using FF 17.0.1 my NVP is in fact currently 11.1.1.5-2, and also my installation on another system of Norton Security Suite ( a clone of N 360) is also 11.1.1.5-2. 

I also checked C:\ProgramData\Norton\{0C55C096-0F1D-4F28-AAA2-85EF591126E7}\NIS_20.1.1.2\IPSFFPlgn\install.rdf on both systems and they also showed the same min version, max version and 11.1.1.5-2 as your file did.

Now here is the kicker - you said you checked:  C:\ProgramData\Norton\{0C55C096-0F1D-4F28-AAA2-85EF591126E7}\NIS_20.2.0.19\IPSFFPlgn  while mine is C:\ProgramData\Norton\{0C55C096-0F1D-4F28-AAA2-85EF591126E7}\NIS_20.1.1.2\IPSFFPlgn\     I beliueve that is no big deal - as I initially downloaded 20.1.1.2 and updated to the current 20.2.0.19 while you may have downloaded 20.2.0.19 and that is the cause of that difference.

I have checked Tony weiss"s post when he announced 17 .0 update and it does in fact show 11.1.1.5-3.

AFAIK, my system is 100% and I have not experienced any problems.  Perhaps others could advise what NVP version they are using and we can get this straightened out.

One more thing, when I post the corrective action you quoted, I always check for current download source and also correct NVP and NTB versions by actually looking at my own system.  What does it say in my post that you followed? 

Kudos0

Re: Norton Vulnerability Protection Will Not Update in Firefox

Hi Brocktoon,

My Vulnerabilty Protection add-on also states "-2," so the "-3" information is probably a misprint in the announcement.  If the toolbar is enabled, everything is fine. 

Kudos0

Re: Norton Vulnerability Protection Will Not Update in Firefox

Thanks for the quick replies!

Atleast I'm not going crazy as the -3 may be a typo.  I thought I read on a post somewhere that the late November update may have brought the NVP up to -3, but that may have just been updating the toolbar extension for FF 17.  I probably went through a bunch of troubleshooting for nothing, but on the positive side it allowed me to get more familar with FF extension and registry system which can only help me troubleshoot better down the road.

Yank,

The recent post that I followed your directions for re-installing did infact mention toolbar 2013.2.2.3 and NVP 11.2.2.5-3, but you were probably going off of Tony Weiss' update post.

Although I recently just registered for this board, I've been reading for quite a while, and this place has been a great treasure trove of tips and advice.  Thanks again folks for doublechecking your systems

Kudos0

Re: Norton Vulnerability Protection Will Not Update in Firefox

Hi Brockton,

Thanks for the feedback and just an FYI - it is best to wait until Norton provides the update for the Norton Toolbar when Firefox does another of their rapid updates (which I believe is schedued for Jan 8th) prior to updating to the latest version of FF.

In order to permit you to do this, please go into Firefox and from the Menu Bar, select Tools > Options > Advanced >Update Tab  and select "Check for updates, but let me decide whether to install them".  That will permit you to keep the update from auto installing until after you receive the NTB compatablility update.

We are quite pleased you find the forums helpful and appreciate your thanks - as volunteers, thanks is the kind of pay we enjoy for our efforts! 

This thread is closed from further comment. Please visit the forum to start a new thread.