• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

NS Premiere - Win 10 Activation fail - no fix!

I purchased NS Premium 10 device to replace multiple Norton products on about 8 devices - 360, Security etc on Win 7, 8, 10 and a few macs. 

After numerous tech chat sessions - with repeated attempts by their remote techs trying every trick in their book - un-installs, re-installs, trial installs then activation, activation repairs, dns flushes and new dns settings etc. Nothing at has worked - thankfully I stopped them before they remotely reformatted my hard drives!

Your techs have claimed to escalate the issue multiple times, and went so far as to schedule and promise call-backs from "specialists" (most recently 4/8/16 at 9:30pm PST), but your team have never followed through, never attempted to contact me at the scheduled time, nor has anyone apologized for keeping me waiting on a Friday evening or for blowing me off altogether. 

This release is a failure due to its inability to activate following upgrade or fresh install, your unpreparedness to manage the thousands of user complaints and issues on the same issue - and the saddest part is you treat customers such as me like shit, and you've apparently got no plans or statements posted outlining how you plan to remedy this widespread problem with your product. 

What an embarrassment. 

Please either resolve the matter once and for all, renew one of my array of Norton product subscriptions at a reasonable price, or refund my purchase or risk losing not only my personal account - but that of my 100+ user company as well to one of your competitors - by the end of this weekend. 

I'm a loyal and longtime Norton user that's at the end of my rope - I've been more than patient but this is simply beyond acceptable. 

I hope someone in a position to actually fix this at least sees it before you lose my business. 

Respectfully, 

~g

Replies

Kudos0

Re: NS Premiere - Win 10 Activation fail - no fix!

Hi, Gforce. I've asked someone from Symantec to contact you. It may be a day or so, as it's the weekend.

Windows 10 Home X 64
Kudos0

Re: NS Premiere - Win 10 Activation fail - no fix!

Are you having trouble on all your devices or just Win 10 installs, as in your thread title?

Did any of the techs suggest turning off the Win 10 Fast Startup feature? If you use Windows 8/8.1 or 10, there can be an issue with the Fast Start feature.. See more information here.

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: NS Premiere - Win 10 Activation fail - no fix!

GF

Doesn't help you resolve the problem you are encountering but FWIW I have NSwBU installed on Windows 7, 8.1 and 10 and all installed without problems and run correctly. I've no experience of Macs.

As Peter asks, some more information will help people help you. Could you say what country/region you are in, if outside the USA, and whether you bought the NSwBU in a store or on line and how you got the installation files?

Anything else you can think of that we should know?

Hugh
Kudos0

Re: NS Premiere - Win 10 Activation fail - no fix!

Hello @GForce,

I'm truly sorry to hear about the problem we've had resolving the activation issue. I've sent you a Private Mail to follow-up. Please look at your Inbox for my message.

Thanks,

Matt

This thread is closed from further comment. Please visit the forum to start a new thread.